This fitness tracker requires iOS 7.1 & above or Android 4.4 & above system.

"Veryfitpro" APP is only compatible with smartphones.

Please notice that type of phones below cannot work with Lintelek fitness tracker:

1.Samsung J series/ S series

2.Huawei P series

Scan to download VeryFitPro APP

For IOS7.1 & above                                  For Android 4.4 & above

activity tracker app download  fitness tracker app